Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 09, 2025 - 08:00 BST
Scheduled
We will be carrying out maintenance on the V2 Reporting in the EU Production environment to satisfy customer legal regulations.
The maintenance window will begin at 8:00AM BST and end at 10:00AM BST on 9th October.
Customer impact:
This will only impact customers that use the V2 Reporting of Maxsight (V1 will be unaffected).
V2 users may experience a longer than usual loading time when they first open the reporting page after the maintenance window. However, this should not be the case for subsequent uses of the reports and dashboards.
If users are experiencing loading issues with the reporting page and dashboards, please attempt to refresh the page a couple of times. If the issue persists following refresh attempts, please contact the Client Services Team.
Posted Oct 08, 2025 - 11:21 BST
This scheduled maintenance affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com).