Maxsight - Delay in Check completion

Incident Report for Moodys

Identified

We are observing platform recovery with checks beginning to complete and complete automation. However, World-Check checks may still experience delays as well as Dow Jones checks. We are continuing to investigate the delays with the mentioned data providers.
Posted Dec 03, 2025 - 15:46 GMT

Update

We are continuing to investigate this issue.
Posted Dec 03, 2025 - 14:59 GMT

Update

We are continuing to investigate this issue.
Posted Dec 03, 2025 - 12:45 GMT

Investigating

We are currently investigating an issue which is causing checks to delay completion and being stuck in "automating" for longer than expected.

Our engineers are working to resolve this as quickly as possible.
Posted Dec 03, 2025 - 10:22 GMT
This incident affects: Maxsight Environments (🇪🇺 EU - eu.maxsight.com).