Google Cloud Outage.

Incident Report for Moodys

Resolved

All Google services have been restored. Maxsight is fully operational again.
Posted Jun 12, 2025 - 20:45 BST

Investigating

Google is currently experiencing multiple outages in EU and US. https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
Posted Jun 12, 2025 - 20:08 BST
This incident affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com, 🇺🇸 USA - us.maxsight.com).