A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2025 - 11:31 BST
Investigating
We are currently seeing issues causing check delays on the EU platform. Our engineers are investigating this issue to identify a resolution as soon as possible.
Posted Jun 24, 2025 - 11:25 BST
This incident affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com).