Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 15, 2024 - 06:30 GMT
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 04, 2024 - 14:48 GMT
Scheduled
We would like to inform you of a scheduled IT maintenance activity that will result in a temporary disruption of our extended support. The maintenance is scheduled for Sunday 15th December from 6.30AM to 10.30AM GMT.
During this period, our support team will be unable to respond any emails and phone calls. The team aim to minimize the downtime and restore services as quickly as possible.
We appreciate your understanding and patience during this maintenance period.
Posted Dec 04, 2024 - 14:47 GMT
This scheduled maintenance affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com, 🇦🇪 UAE - ae.maxsight.com, 🇺🇸 USA - us.maxsight.com).