A fix has been implemented and we are actively monitoring.
Posted Jun 23, 2026 - 17:37 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 23, 2026 - 16:07 BST
Investigating
We are currently experiencing performance issues on https://xus.maxsight.com/ affecting assessment runs and resulting in longer screening times. Our engineering team is actively working to identify and resolve the issue as quickly as possible. Thank you for your patience.
Posted Jun 23, 2026 - 15:22 BST
This incident affected: Maxsight Environments (🇺🇸 USA - xus.maxsight.com).