Performance issues in M4C

Incident Report for Moodys

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 14:32 BST

Update

We are continuing to investigate this issue.
Posted Jun 04, 2026 - 14:25 BST

Update

We are continuing to investigate this issue.
Posted Jun 04, 2026 - 13:19 BST

Investigating

We are currently experiencing performance issues within M4C. This may result in slower screening processes and delays in completing tasks after screening matches are acknowledged.

Please rest assured that our team is actively working to resolve the issue as quickly as possible. We apologise for any inconvenience this may cause and appreciate your patience.
Posted Jun 04, 2026 - 11:19 BST
This incident affected: Maxsight Environments (🇺🇸 USA - xus.maxsight.com).