Degraded performance: Orbis checks & company search

Incident Report for Moodys

Resolved

This incident has been resolved
Posted May 30, 2026 - 15:50 BST

Monitoring

A fix has been implemented and we are monitoring the results
Posted May 30, 2026 - 14:25 BST

Investigating

We are currently investigating this issue
Posted May 30, 2026 - 13:10 BST
This incident affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com, 🇦🇪 UAE - ae.maxsight.com, 🇺🇸 USA - us.maxsight.com).