A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2026 - 09:42 BST
Update
We are continuing to investigate this issue.
Posted Jul 17, 2026 - 09:17 BST
Investigating
We are actively investigating a performance issue causing slow system response times and login difficulties, including instances where users encounter a white screen.
Posted Jul 17, 2026 - 08:59 BST
This incident affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com).