Maxsight security upgrade - SSOv2+MFA

Incident Report for Moodys

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 09:48 BST

Monitoring

Dear customer,

As you're aware we have migrated to Moody's SSOv2 and on MFA this afternoon for our security enhancement.

Please check your emails to get the activation link and complete the registration process.
Help page for your reference: https://help.maxsight.com/en/activate-your-moody-s-sso-account

In case you didn't receive the Moody's SSO activation email please check your spam/junk folder, whitelist our domain by reaching out to your IT team(idm-no-reply@moodys.com, no-reply@moodys.com), before you reach out to Client Service Team.

If the workaround shared doesn't work for you please email our client service team at clientservices@moodys.com

Please note you will still be able to login by using the legacy login url without any business interruption. Please use this link according to your region.
URL: .maxsight.com/login_legacy

Note: If you didn't receive an activation email yet or still not able to login because of encountering any errors, please contact us by sharing all the relevant information.

Thank you for your support and understanding.
Posted Sep 30, 2025 - 17:50 BST
This incident affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com, 🇦🇪 UAE - ae.maxsight.com, 🇺🇸 USA - us.maxsight.com).