Degraded Performance - Search & Entity Management (Indexing Delay)

Incident Report for Moodys

Resolved

This incident has been resolved.
Posted May 21, 2026 - 15:16 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 21, 2026 - 13:50 BST

Investigating

We are currently investigating an issue affecting the search service, where delays in the indexing process are preventing newly created profiles from appearing in search results and the Entity Management view.
Users may experience:

- Newly created profiles not visible in search
- Records not appearing in the Entity Management section
- Delays in profile availability across environments

Our engineering team is actively investigating the root cause. We will provide further updates as more information becomes available.
Posted May 21, 2026 - 12:06 BST
This incident affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com).