Moody's for Compliance Screening Slowness

Incident Report for Moodys

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 03, 2026 - 14:45 BST

Investigating

We are actively investigating an issue causing slowness in screening. Users may experience delays in receiving screening results and with screening decisioning.
Posted Aug 03, 2026 - 14:36 BST
This incident affects: Maxsight Environments (🇺🇸 USA - xus.maxsight.com).