Orbis Data sync issue

Incident Report for Moodys

Postmortem

Root Cause Analysis - Orbis Data Sync Failure (2nd June 2025)

Impact
On 2nd June, Maxsight’s Orbis data replica was not updated as expected, causing delays in providing the latest information to customers.

Root Cause
The issue occurred when the data provider updated their server keys without notifying Maxsight, which prevented the data sync from starting. Subsequent attempts to sync were also delayed due to connection issues.

Resolution
We resolved the issue by updating the server credentials and addressing the connection issues to ensure the data sync completed successfully on 15th June.

Prevention Measures Scheduled

  • Implement proactive notification of any changes by our data providers that could impact data updates.
  • Improve monitoring to identify syncing issues earlier.
  • Enhance the reliability of the data sync process.
Posted Jun 23, 2025 - 16:49 BST

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 09:50 BST

Monitoring

A fix has been implemented and we are monitoring the sync progress.
Posted Jun 03, 2025 - 12:36 BST

Update

We are continuing to investigate the issue.
Posted Jun 02, 2025 - 17:59 BST

Investigating

We are currently investigating an issue with the data sync between Orbis and Maxsight. This means that Orbis data checks may not show the latest available data due to the sync delay. Our engineers are working to resolve this as quickly as possible.
Posted Jun 02, 2025 - 12:32 BST
This incident affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com, 🇦🇪 UAE - ae.maxsight.com, 🇺🇸 USA - us.maxsight.com).