Screening inquiries are now returning results at the expected speeds. The issue was caused by a number of inquiries generating an error and continuously retrying. We will be working to improve the error handling and retry logic to prevent similar issues in the future.
Posted Jun 23, 2026 - 10:52 BST
Monitoring
Screening inquiries are now returning results at expected speeds. We are continuing to investigate the root-cause behind the original delays.
Posted Jun 23, 2026 - 10:40 BST
Investigating
We are currently experiencing a severe delay in screening inquiries returning results in Moody's for Compliance within the US environment. This is being investigated as an urgent priority by our engineers.
Posted Jun 23, 2026 - 09:59 BST
This incident affected: Maxsight Environments (🇺🇸 USA - xus.maxsight.com).