Slow Performance in EU

Incident Report for Moodys

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 17:13 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2026 - 17:12 BST

Update

The issue has been identified and a fix is being implemented. We are started seeing improvements in the system.
Posted Apr 21, 2026 - 16:46 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 21, 2026 - 14:55 BST

Update

Our engineers are continuing to investigate the issue.
Posted Apr 21, 2026 - 14:42 BST

Update

We are continuing to investigate this issue.
Posted Apr 21, 2026 - 14:10 BST

Update

We are continuing to investigate this issue.
Posted Apr 21, 2026 - 13:39 BST

Update

We are continuing to investigate this issue.
Posted Apr 21, 2026 - 12:44 BST

Update

We are continuing to investigate this issue.
Posted Apr 21, 2026 - 12:11 BST

Update

We are continuing to investigate this issue.
Posted Apr 21, 2026 - 11:27 BST

Investigating

We’re aware of an issue causing slow performance on the Maxsight EU platform, such as delays in loading pages or profiles staying in the "automating" status longer than expected.

Our team is actively working to resolve this and restore full functionality as quickly as possible.

Thank you for your patience.
Posted Apr 21, 2026 - 10:41 BST
This incident affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com).