Dow Jones checks failing in EU

Incident Report for Moodys

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 11:45 BST

Investigating

We are currently seeing Dow Jones checks failing in the EU environment. Our engineers are currently investigating to resolve this issue as quickly as possible.
Posted Jun 23, 2025 - 09:48 BST
This incident affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com).