Maxsight EU - Issue downloading Audit Reports

Incident Report for Moodys

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 10:06 BST

Update

We are continuing to work on a fix for this issue.
Posted Oct 09, 2025 - 09:21 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 08, 2025 - 16:01 BST

Investigating

We are currently investigating an issue affecting users in the Maxsight EU environments, where audit reports are either not downloading or experiencing significant delays.

Our engineering team is actively working to resolve this as quickly as possible.
Posted Oct 08, 2025 - 15:19 BST
This incident affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com).