Maxsight All Regions- Grid screening delays

Incident Report for Moodys

Update

We are continuing to monitor for any further issues.
Posted Dec 12, 2025 - 15:54 GMT

Update

We are continuing to monitor for any further issues.
Posted Dec 12, 2025 - 10:19 GMT

Update

Although we are seeing improvements in GRID screening completion, we are still observing checks taking longer than expected to complete. We are continuing to work on a permanent solution.
Posted Dec 12, 2025 - 10:05 GMT

Update

We are continuing to monitor for any further issues.
Posted Dec 12, 2025 - 09:46 GMT

Update

We are seeing significant improvement since deployment of the fix but we are continuing to monitor the situation until confirmation of full resolution
Posted Dec 11, 2025 - 16:32 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 11, 2025 - 16:04 GMT

Update

We are continuing to work on a fix for this issue.
Posted Dec 11, 2025 - 15:05 GMT

Update

We are seeing an increase in number of Grid checks being stuck in progress for longer than expected. We are working to resolve this matter and restore service to normality as quickly as possible.
Posted Dec 11, 2025 - 14:34 GMT

Identified

We are seeing improvements in Grid check performance but we are continuing to investigate and ensure full resolution.
Posted Dec 11, 2025 - 09:04 GMT

Update

We are continuing to investigate this issue.
Posted Dec 10, 2025 - 15:09 GMT

Investigating

We are currently investigating an issue which is causing Grid screening checks to be stuck in automating status for longer than expected.

Our engineers are working to resolve this as soon as possible.
Posted Dec 10, 2025 - 10:47 GMT
This incident affects: Maxsight Environments (🇪🇺 EU - eu.maxsight.com, 🇦🇪 UAE - ae.maxsight.com, 🇺🇸 USA - us.maxsight.com) and Integration Hub (Moody’s Grid).