Elevated API errors for GRID Screenings

Incident Report for Moodys

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 16:45 GMT

Update

We are continuing to monitor for any further issues.
Posted Mar 04, 2026 - 15:06 GMT

Update

We are continuing to monitor for any further issues.
Posted Mar 04, 2026 - 14:26 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2026 - 12:51 GMT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 04, 2026 - 11:25 GMT

Update

We are continuing to investigate this issue.
Posted Mar 04, 2026 - 10:53 GMT

Update

We are continuing to investigate this issue.
Posted Mar 04, 2026 - 10:00 GMT

Update

Please note that this issue is also impacting GRID screening where users are being presented an "Internal Server Error". Our engineers are continuing to investigate the issue.
Posted Mar 04, 2026 - 09:41 GMT

Update

We are continuing to investigate this issue.
Posted Mar 04, 2026 - 09:25 GMT

Update

We are continuing to investigate this issue.
Posted Mar 04, 2026 - 09:11 GMT

Investigating

Maxsight is currently experiencing a higher number of API errors related to RDC/GRID, which is also impacting the Maxsight portal.

Our engineering team is actively investigating the issue to identify the root cause and implement a resolution.

We will provide another update within 30 minutes.
Posted Mar 04, 2026 - 09:09 GMT
This incident affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com, 🇦🇪 UAE - ae.maxsight.com, 🇺🇸 USA - us.maxsight.com).