Moody for Compliance (M4C) - Issue adding entities to Porfolio

Incident Report for Moodys

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 09:07 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2026 - 13:26 BST

Investigating

We are investigating an issue that prevents users from adding entities to the portfolio in Moodys for Compliance. We will provide a further update shortly.
Posted Jul 17, 2026 - 12:43 BST
This incident affected: Maxsight Environments (🇺🇸 USA - xus.maxsight.com, 🇪🇺 EU - xeu.maxsight.com).