We are continuing to monitor following actions taken to restore service.
Posted Jun 03, 2026 - 11:52 BST
Monitoring
We have taken measures to help restore service and we are currently monitoring the situation.
Posted Jun 03, 2026 - 11:06 BST
Investigating
We are aware of an issue affecting the display of new profiles and entities on the Entity Management page, as well as some inaccuracies in profile and entity search results. Our engineering team is actively working to resolve this as quickly as possible. Thank you for your patience.
Posted Jun 03, 2026 - 10:28 BST
This incident affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com).