We are continuing to monitor for any further issues.
Posted Mar 05, 2026 - 14:33 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2026 - 13:43 GMT
Update
We are continuing to investigate this issue.
Posted Mar 05, 2026 - 13:06 GMT
Update
We are continuing to investigate this issue.
Posted Mar 05, 2026 - 12:18 GMT
Update
We are continuing to investigate this issue.
Posted Mar 05, 2026 - 11:14 GMT
Update
We are continuing to investigate this issue.
Posted Mar 05, 2026 - 10:45 GMT
Update
We are continuing to investigate this issue.
Posted Mar 05, 2026 - 10:09 GMT
Investigating
We are currently investigating an issue causing the platform to run very slowly and users are being presented with a white loading screen. Our engineers are actively investigating this to return service to normal as quickly as possible.
Posted Mar 05, 2026 - 09:27 GMT
This incident affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com).