Elevated Orbis errors

Incident Report for Moodys

Resolved

This incident has been resolved.
Posted Jun 09, 2026 - 09:41 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 09, 2026 - 08:41 BST

Investigating

Maxsight is experiencing a higher number of errors with the Orbis data provider.

Our engineering team is currently working to identify the root cause.
Posted Jun 09, 2026 - 07:26 BST
This incident affected: Maxsight Environments (🇪🇺 EU - eu.maxsight.com, 🇦🇪 UAE - ae.maxsight.com, 🇺🇸 USA - us.maxsight.com).